Jump to content
Sign in to follow this  
Guest MustI

OpenVPN Server/Client insecure cipher with block size less 128

Recommended Posts

Guest MustI

VPN server allows the client to use insecure cipher

WARNING: INSECURE cipher with block size less than 128 bit (64 bit).  This allows attacks like SWEET32.  Mitigate by using a --cipher with a larger block size (e.g. AES-256-CBC).
WARNING: INSECURE cipher with block size less than 128 bit (64 bit).  This allows attacks like SWEET32.  Mitigate by using a --cipher with a larger block size (e.g. AES-256-CBC).
 

Share this post


Link to post
Share on other sites
ro.prince

Have you resolved this issue? I am having this issue and can't seem to resolve it.

Share this post


Link to post
Share on other sites
StefanWAustin

This is not an issue, because the encryption does not matter for a lab. In a real environment a very strong encryption is a must for sensitive data, but e.g. a nmap scan is not important.

Share this post


Link to post
Share on other sites
StefanWAustin
18 minutes ago, Guest Andrew said:

I have same problem...you have fix it?

That is not an error, the VPN uses a weak encryption method, but for a lab it is not important at all.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×