Jump to content

MITM - Rogue AP

Recommended Posts


Hi Guys,


I am going through WIFI Security Module 7 , where I tried to create MITM attack in my home lab.

using the instructions given in the slides i was able to create at0 virtual interface and run airbase-ng and bridged eth0 & at0 . When i tried to connect a client, I was not getting IP from DHCP server.


So, i followed instructions below to start DHCP server :



# nano /etc/dhcp/dhcpd.conf

default-lease-time 600;

max-lease-time 7200;
option domain-name-servers,;
option domain-name "yourdomainname.com";

subnet netmask {
range; ‪#‎Range‬ of client's IP addresses: 150 to 200
option subnet-mask;
option broadcast-address;
option routers;

Restart dhcp-server
# /etc/init.d/isc-dhcp-server restart


That helped me to get IP on my client now when i tried to connect to my Rogue AP but as I don't have physical LAN connectivity, so no internet via eth0.

What i would like to do is to use my wlan1 inteface (which is connected to internet) and bridge it to at0 but I am getting error. I tried to follow instructions in this forum as well but still can't get internet on my client.



any help will be appreciate.





Share this post

Link to post

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now